Customers are showing a phone number of 15005550006 or 1234567890 post-import
Relevant to:
Shopify Checkout Integration
Issue
If you notice that some customers in your migrated data have the phone number 15005550006 or 1234567890 post-import, this indicates that our system has automatically generated a default number.
Environment
- Shopify Checkout Integration
Cause
This typically occurs when:
- Your Shopify settings require a phone number at checkout
- The
shipping_phonefield was left empty in the migration file during import
Resolution
Note: The instructions in this guide only affect the shipping address phone number, not the main customer profile phone number.
To fix this issue:
1. Disable the relevant Shopify setting
- In your Shopify admin click Settings and select Checkout.
- Select Optional under Shipping Address Phone Number.
2. Perform a bulk update to clear existing records
- In the Recharge merchant portal, go to Tools & apps and select Exports. Export Customers - Shipping Addresses.
- In the CSV, replace the default phone numbers with
Null. - Remove any extra columns. There should only be the two columns left:
address_idandphone. - Complete the bulk update. See steps 2 & 3 in our Bulk updating subscriptions guide.
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