Contract not available error
Issue
The error message Contract not available appears on the Customer Details page in Recharge.
Environment
- Shopify Checkout Integration
- Migrated Shopify Checkout Integration
Cause
Recharge can only create a subscription contract when a customer checks out through Shopify. In rare cases, a delay or webhook failure can prevent the contract from being created. This results in the subscription appearing in Recharge without a valid contract or sometimes not appearing at all.
This issue may appear after migrating to the Shopify Checkout Integration (SCI), sometimes showing as a NO_CONTRACT_AVAILABLE error on a recurring order.
Resolution
In most cases, Recharge Support can manually create the contract to resolve the issue. Follow these instructions:
- Verify that customer details are complete and accurate. Shopify enforces stricter address validation than Recharge Checkout.
- Confirm the province/state and postal or ZIP code are valid and correctly formatted.
- Confirm the customer has both a first and last name on file.
- Reschedule the charge for today or a future date to trigger contract creation and complete the charge.
- Ensure the recurring product and variant have a valid selling plan configured. If there are no plans or the plans are removed, a contract cannot be created.
- If the issue persists, Contact Recharge Support to check for a missing contract. We will create the contract if possible.
- If a contract cannot be created, the subscription will need to be cancelled and the customer will need to go through the checkout again to start a new subscription and create the contract.
