'You already applied a discount code' error
Relevant to:
Shopify Checkout Integration
Recharge Checkout on BigCommerce
BigCommerce Integration
Migrated Shopify Checkout Integration
Issue
The error message You already applied a discount code appears after attempting to process a bulk discount application.
Environment
Platform: Cross-platform
Cause
If a customer's address ID already has a discount code applied, running a bulk discount application will result in an error for those addresses after processing.
Resolution
To resolve the error you must do one of the following:
- Remove the addresses with the error from the file and reprocess the update.
- Manually or bulk remove the discount codes from the addresses with the error and try the bulk update again.
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