Upcoming order email analytics are not updating
Issue
Summary data for Upcoming order emails is incomplete or analytics displays 0/0% recipients for key metrics.
Environment
- Shopify Checkout Integration
- Migrated Shopify Checkout Integration
- BigCommerce Checkout Integration
Cause
When the SendGrid integration is enabled on Recharge it prevents Recharge from receiving the necessary event data to track and report on email performances. This leads to discrepancies and missing information in the Upcoming order emails analytics.
Resolution
To ensure your Upcoming order email analytics are complete and accurate, you must disable the SendGrid integration in Recharge and duplicate your current Upcoming order email flow.
Disable the SendGrid Integration
- In the Recharge merchant portal, go to Tools & Apps.
- Click on Installed Apps.
- Find and select the SendGrid app.
- Click Uninstall App.
Duplicate your existing Upcoming order email
After disabling the SendGrid integration, duplicate your existing Upcoming order email.
- In the Email setting, click on Upcoming Order email template.
- Click on the email you want to duplicate
- Press the vertical three-dot menu and select Duplicate.
- Activate the duplicated Upcoming order email strategy.
Duplicating and activating the strategy ensures that Recharge begins receiving and calculating accurate metrics for new notifications, including delivery, open, and click events.
Verify Upcoming order email analytics
After disabling the SendGrid integration and duplicating your existing Upcoming order email, review your Upcoming order email analytics to confirm metrics are now updating as expected.
If you use customized Upcoming order notifications, check that your settings remain correct and active.
It is also recommend to Authenticate your domain in Recharge to meet DMARC requirements and improve deliverability.
