Cannot remove a customers subscription payment method in Shopify
Issue
You can't remove a saved payment method for a subscription in Shopify because the Delete or Remove option appears greyed out.
Environment
- Shopify Checkout Integration
- Migrated Shopify Checkout Integration
Cause
This issue can occur for one or more of the following reasons:
- Shopify still links the payment method to an active subscription.
- A subscription was recently cancelled but Shopify still treats the payment method as in use.
- Recharge and Shopify are temporarily out of sync.
Resolution
Confirm the payment method is not linked to any active subscriptions.
If all subscriptions are cancelled and the Delete or Remove option is still unavailable, contact Recharge Support to request a manual sync. If the manual sync does not resolve the issue, contact Shopify Support for further assistance.
If the customer uses PayPal, they must update or remove the payment method directly in their PayPal account.
