Why was my order successful in Recharge but shows "Pending" in Shopify?
Issue
An order appears as successful in Recharge but the corresponding order in Shopify shows a Pending status.
Environment
- Shopify Checkout Integration
- Migrated Shopify Checkout Integration
This occurs for merchants using Authorize.net as their payment gateway in Shopify.
Cause
Shopify updated how they handle Authorize.net recurring orders that are flagged by the Authorize.net Suspicious Transaction Filter. When a transaction is held for review by Authorize, Shopify reflects the order as Pending, even though Recharge shows the order as successfully created.
Resolution
Merchants must log in to Authorize.net and manually review and approve the flagged transaction in order to resolve the Pending status in Shopify.
