Cancellation Prevention conditional branch not working for specific product cancellation
Issue
Customers are not going to the appropriate branch when a line-item condition is used within a Cancellation Prevention conditional branch. This may cause the same survey to show for customers cancelling different products or the wrong branch survey.
Environment
- Shopify Checkout Integration
- Migrated Shopify Checkout Integration
Cause
If a Cancellation Prevention flow utilizing conditional branching contains a condition for "Line item", this condition runs agains the line items in the next queued charge.
Resolution
To avoid issues, ensure the customer goes down the appropriate branch for the product they are attempting to cancel by using the "Subscription being cancelled" condition instead of the "Line item" condition.
